Adobe Photoshop is a rare software application that entices people to acquire skills beyond an introductory level of knowledge, because it is actually enjoyable to learn and encourages experimentation. As the year 2000 brought us to Photoshop's tenth anniversary, I am still awestruck at the power it possesses as an image editing/creation program. With the inclusion of the ImageReady tools, it is the preeminent image application for Web graphics, regardless of whether you use the PC or Macintosh platform.

Roger P. Shepard, Jr.
Digirati Studios, Shirley, MA
http://www.digiratistudios.com
Chapter 1: Macintosh, Windows, and Photoshop

When designers launch Adobe Photoshop on their computer desktops, they know that they are about to work with the most powerful and respected photo-manipulation and graphics application currently on the market. The first seven chapters of this book will investigate that application. This chapter focuses upon the Photoshop interface and the differences in its appearance and behavior on the Macintosh and the Windows operating systems—including Windows 2000. Some significant changes to Photoshop appear in versions 5.5 and 6.0, so these are examined. Basic graphics issues such as file type and sizes are discussed here.

The chapter also includes a history of Photoshop, and a sidebar containing a capsule history of computer-human interface issues as they relate to graphics and media on the machine. Every designer should have a sense of where our tools came from. Future developments, predicted or desired, in cyberspace and design are found in Chapter 20.
The Photoshop interface has developed over the years. It was first developed by Thomas and John Knoll from Ann Arbor, Michigan. John needed an image processing program for his computer work in California at George Lucas’s special effects company, Industrial Light and Magic, so Thomas developed one for him. After writing various plug-ins for it, John pitched it as a product, finally to Adobe in 1988.

Early in Photoshop’s development John Knoll designed an application icon for the program showing a little drive-in photo developing booth with an employee standing ready at the cash register.

Photoshop has several windows that by default are open on your desktop.

Palettes can be moved, hidden, collapsed or expanded, resized, or customized. Each tool has its unique palette.

Let’s consider the history of this exciting and versatile graphics program, and then explore its carefully developed interface.

Photoshop is not the only desktop photo retouching tool, only the most successful, versatile, and long-lasting. PhotoMac was on the market shortly after the first color Macintosh appeared in 1987, well before Photoshop. Fractal Design’s ColorStudio was a strong competitor to Photoshop 1.0 in 1990. Aldus, the original
developer of PageMaker, had a product called PhotoStyler until the company was purchased by Adobe. LivePicture, from MetaCreations, had layers before Photoshop did. In the mid 1990s Macromedia published a product called x-Res. Barneyscan XP, which shipped bundled with Barneyscan scanners, was actually an early version of Photoshop before it came to be distributed by Adobe. Some Windows users prefer to use more task-specific limited graphics applications like Professor Franklin’s Instant Photo Effects and LView Pro. Raise a toast to them all . . . but spend your time learning Photoshop, for it’s here to stay.

Milestones in Photoshop History

1990
Photoshop 1.0: The program first appears for the Macintosh platform only.

1991
Photoshop 2.0: First Windows version. CYMK color made Photoshop useful for the printing industry. The Pen tool added.
Photoshop 2.5: Dodge and Burn tools added, based on traditional darkroom functions in photography.

1994
Photoshop 3.0: Editable layers, perhaps the breakthrough feature that added the greatest functionality to Photoshop.

1996

1998
Photoshop 5.0: The History palette added to allow multiple Undo. The History Brush feature added.

1999
Photoshop 5.5: Web graphics functions enhanced. Image Ready 2.0 bundled as an extension.

2001
Photoshop 6.0: Slices, Notes, and other Toolbar changes added. Text manipulation on canvas, not dialog box. Image Ready 3.0 bundled as an extension.

For more historical information and anecdotes, see Jeff Schewe's excellent article “10 Years of Photoshop: The Birth of a Killer Application” in Photo > Electronic Imaging magazine (www.peimag.com), February 2000.
Some GUI and Web History

Some sense of the history of GUI (graphic user interface) design is important for the contemporary Web designer, as the Web as we know it is not a natural phenomenon like the stars in the sky but is the result of years of development, products, experiments, and technologies. It is the coming together of historical developments in computer graphics, interface metaphors, computer science, telecommunications, and business. All this knowledge is helpful to users of a highly refined and developed application like Photoshop. You are encouraged to use this narrative as a guide to your own further research.

The first to display graphics instead of merely text on computers in the 1960s was Ivan Sutherland. These were simple vector graphics, where a graphic object is defined by the mathematical coordinates of its endpoints, or a circle defined by its center and radius. The other way graphics can be defined is by the computer noting the precise location of each pixel (picture element) on the screen’s raster or display grid, with information on that pixel’s color. Needless to say, this kind of graphic, called bitmapped, is more memory-intensive but proved to be an effective way to display onscreen an image input from a continuous-tone photograph.

The two kinds graphics continued to develop. Vector graphics objects were used for design and illustration programs like MacDraw and CorelDRAW (as well as 3D graphics), while bitmapped programs like MacPaint, Electronic Arts’ Studio8, and in 1990, PhotoShop appeared.

Parallel to all this is the development of what became the World Wide Web. Computers were networked in the 1960s in experiments at Xerox’s Palo Alto Research Center (PARC) and elsewhere, and Vinton Cerf helped develop the TCP/IP protocol, which meant the network could run over the phone lines. The United States Department of Defense funded projects that could result in a decentralized network among military, government, and universities. On this Internet email was exchanged and text or graphic files (including Compuserve’s economical GIF format) could be attached . . . but in the 1980s the only images visible were whatever icons came on your email program. Consequently, this excellent public resource was hardly utilized and undeveloped by today’s standards.

The first to put information in onscreen windows and link them was Douglas Engelbart, who also invented the mouse. Networked hyper-
media was first proposed by the filmmaker/computer scientist Ted Nelson around 1960. Yet it was Tim Berners-Lee at the European research laboratories CERN who first came up with a way to display on-screen “pages” of text with imagery. This prompted college student Marc Andressen and friends to develop a browser called Mosaic to view these documents easily. When Silicon Valley industrialist Jim Clark saw it, he hired Andressen and gang to his new company Netscape. When Bill Gates and Nathan Myrvhold saw what was going on, Microsoft developed the Internet Explorer browser. And when students, scholars, scientists, artists, and businesspeople all over the world saw how their own work could be furthered with online publishing—of text, graphics, and multimedia—it brought us to today’s World Wide Web.

Lab 1.1 Exercises

1.1.1 Explore Photoshop’s Interface

These exercises assume that you are new to Photoshop, and will open the application and walk you around it, investigating various components on a general level. You may have already explored like this when you first installed the program on your computer. If that is the case, skim the exercises and proceed to the next Lab.

Open Photoshop.

a) Is the Navigator window (Figure 1.1) open by default when you open Photoshop? Observe.

Figure 1.1 ■ The Navigator window.
b) What happens when you slide the zoom slider?

c) What do the little mountains represent? Experiment to find out by clicking and performing other operations.

d) Open the file "frank.psd" (Figure 1.2). Select the eyedropper and click anywhere upon the "frank.psd" canvas. What has happened?

Figure 1.2 ■ frank.psd.
8 Lab 1.1: The Photoshop Interface

e) What happens when you click the eye at the top of the Tools palette? Observe.

f) Open “venice.psd” (Figure 1.3) in Photoshop. Zoom in to 400% to examine the pixels more closely. How do you think you move in for a close-up view?

Figure 1.3 - venice.psd.

g) Perform a transformation to this image from the Menu bar. From the Menu bar choose the Filters menu and select one of the filters listed. Observe what happens.
h) Your image has been transformed by the filter, but you decide you don't want to keep it that way. What are the two ways that you could undo that transformation?

i) What do the various tabbed palettes grouped with History show you?

j) Now select the tool from the toolbar that looks like a little paintbrush—do not choose the little brush with an arrow orbiting it—and make a brushstroke upon your image, not for any practical purpose on the image but to examine the Options. After you have made the stroke, doubleclick on the Paintbrush tool. What do the various tabbed palettes that come up show you?

k) How can the Photoshop user access other palettes that appear listed under the Window menu?

### 1.1.2 EXPLORE PHOTOSHOP 5.0, 5.5, AND 6.0

Version 5.0 saw many changes from previous versions of Photoshop, welcome additions to its range of functionality. These features appear in the later versions of the program as well. Let us now explore some of them.
a) If you've worked with Photoshop extensively in the past, take a careful look at the toolbar (Figure 1.4). Do the buttons’ look and feel appear identical to the previous versions?

Figure 1.4 ■ The Photoshop toolbar.

b) Roll the cursor over the tools in the toolbar. How does the interface now educate the novice Photoshop user?
c) Open “venice.psd” in Photoshop. Choose the Paintbrush icon and make a random swipe upon the image. Choose the Pencil icon and drag a line across the image. Choose the Eraser icon beside it and drag over part of the image, erasing it. If you like, make one or two other actions upon the image with any tool of your choice.

Open the History palette by clicking on the History/Actions palette. If it’s not onscreen, choose Show History from the Window menu in the menu bar at the top of your screen. How can you use this function of Photoshop to remove the marks you have made upon your image?

d) Suppose you are ready to save the work you performed upon a graphic project. Open the File menu on the menu bar at the top of your screen and choose Save for Web. What do all these multiple images and choices presented to you mean?

d) Click on the little Adobe logo at the lower right bottom of the toolbar, whose Tooltip tells you it is the Jump to command. What takes place?

**Lab 1.1 Exercise Answers**

This section gives you some suggested answers to the questions in Lab 1.1, with discussion related to those answers. Your answers may vary, but the most important thing is whether your answer works. Use this discussion to analyze differences between your answers and those presented here.
If you have alternative answers to the questions in this Exercise, you are encouraged to post your answers and discuss them at the companion Web site for this book, located at http://www.phptr.com/phptrinteractive.

1.1.1 Answers

a) Is the Navigator window open by default when you open Photoshop? Observe.

Answer: Windows that open by default when you open Photoshop include one window that contains the Navigator, Info, and Tool options. Photoshop windows are logically grouped, letting you jump from one to another by clicking on their tabs.

Navigator allows you to zoom in by a certain amount by using a slider, while showing the image area in a red rectangle upon a miniature of your entire canvas.

Info contains the color RGB or CYMK (these terms will be explained in Chapter 8) values for the color of any pixel as selected by the Eyedropper. It also plots the cursor position and shows width and height of the file.

The options are always specific to the tool you have chosen in the toolbar. When a tool is selected, the options are then named for the tool, like Move Options, Pencil Options, Paintbrush Options.

b) What happens when you slide the zoom slider?

Answer: The zoom slider changes your view by zooming in and out of your graphic.

c) What do the little mountains represent? Experiment to find out by clicking and performing other operations.

Answer: To the left of the slider is an icon of little mountains that allow you to zoom out by fixed amounts in steps. To the right of the slider is an icon of bigger mountains that allow you to zoom in by fixed amounts in steps.

d) Open the file “frank.psd.” Select the eyedropper and click anywhere upon the “frank.psd” canvas. What has happened?

Answer: The eyedropper has selected the color of the pixel you have clicked. You could now paint with this color using one of Photoshop’s painting tools or modify the color. If you click elsewhere, you will see the color of any pixel you click-selected.

e) What happens when you click the eye at top of the Tools palette? Observe.
Lab 1.1: The Photoshop Interface

Answer: A click upon the eye at the top of the Tools palette takes the user to Adobe Online by automatically logging on and connecting you to relevant information on Adobe’s Web site. There is no Tooltip for this function, so the user has to click it to find out its purpose.

At the Adobe Web site the Photoshop user finds much useful and relevant information about the program and other Adobe products, from tutorials and training to troubleshooting information, power-user tips, and much provocative photo imagery by various artists. The Photoshop user is urged to visit periodically to keep abreast on the program’s development and its user community.

f) Open “venice.psd” in Photoshop. Zoom in to 400% to examine the pixels more closely. How do you think you move in for a close up view?

Answer: On the toolbar is the Magnifying Glass.

You will need to change your view while working in Photoshop. Like a dancer, you will move in and out. Like Muhammed Ali in the boxing ring, you will bob and weave (“float like a butterfly, sting like a bee” is a good policy in creating graphics, too) for the best view and the best angle of attack.

If you work on a level of high magnification to tweak your image, be sure to check it every now and then at 100%. This is how the world will view it. Sometimes an image that makes sense magnified breaks down when seen actual size, because of some peculiarity of how the eye views adjacent colors or how they appear onscreen. The gestalt, or first glance taken in by the eye and brain, is of prime importance.

Tools on the toolbar will be explored in further detail in Chapter 4.

g) Perform a transformation to this image from the Menu bar. From the Menu bar choose the Filters menu and select one of the filters listed. Observe what happens.

Answer: Controls will have appeared that let you adjust the filter, and its default value will have been applied to your image’s thumbnail, for you to either Cancel, adjust, or click OK if the default value is what you want.

Filters will be explored in further detail in Chapter 7.

h) Your image has been transformed by the filter, but you decide you don’t want to keep it that way. What are the two ways that you could undo that transformation?

Answer: You could undo that filter’s transformation with a simple Undo, enabled in the manner that works in most applications on your computer. The first way would be to
choose Undo from the File menu. The second way would be to use a Control-Z on Windows or Command-Z on the Macintosh.

Until version 5.0 it was imperative that you know Undo while working on Photoshop, and it’s still a good idea and handy to know its key command.

Yet there is a third way to Undo, and this is the most interesting and unique to Photoshop. We will discuss it in Exercise 1.1.2 when we cover the new features added to Photoshop 5.0.

i) What do the various tabbed palettes grouped with History show you?

Layers show the various layers that make up your image. This is useful as Photoshop assembles multiple images into one composition. For further information on Layers, please see Chapter 3.

Channels shows the multiple color channels and any image masks being employed by your image. For further information on channels and masks, please see Chapter 5.

Paths is the name of the palette used by the Pen tool. For further information on paths and the Pen tool, please see Chapter 6.

Following the History palette is the Actions palette. This palette collects and controls the sequence of automated tasks grouped into what Photoshop calls an action. It also shows sets, which are groups of actions.

j) Now select the tool from the toolbar that looks like a little paintbrush—do not choose the little brush with an arrow orbiting it—and make a brushstroke upon your image, not for any practical purpose on the image but to examine the options. After you have made the stroke, double-click on the Paintbrush tool. What do the various tabbed palettes that come up show you?

Answer: The Paintbrush options palette gives you controls that are unique or particular to the Paintbrush tool, including color mode and opacity. Each tool has its options palette customized for it.

By clicking the tab beside the title Options, you bring up the Info palette. As you move your cursor around the screen, you will see the Info palette reflect the RGB and CMYK color values of the color beneath the cursor, as well as the cursor position.

By clicking the tab beside the title Info, you bring up the Navigator palette. Moving its slider allows you to enlarge or decrease your view of the image, showing numerically the degree of magnification or reduction. When zoomed in, you can move the little red rectangle on the Navigator to change which part of the image you are viewing.

Tools on the toolbar will be explored in further detail in Chapter 4.
k) How can the Photoshop user access other palettes that appear listed under the Window menu?

Answer: Palettes that appear listed under the Window menu may be hidden and can be brought to the forefront. Their names are preceded by “Show,” such as Show Navigator, Show Color, Show Swatches, Show Layers.

The tab that is currently open always offers in the Windows menu the choice “Hide,” to hide that palette.

This has been just a high-level and cursory overview of how Photoshop works. Subsequent chapters will examine this application’s capabilities in greater depth.

1.1.2 Answers

a) If you’ve worked with Photoshop extensively in the past, take a careful look at the toolbar. Do the buttons’ look and feel appear identical to the previous versions?

Answer: The toolbar became a bit more dimensional, with drop shadows on the tools’ icon buttons and a gray background separating the black and white picture icon from its background.

b) Roll the cursor over the tools in the toolbar. How does the interface now educate the novice Photoshop user?

Answer: One useful addition to Photoshop 5.0 and above are Tooltips, those little yellow pop-up descriptions of tool when you rest the cursor upon it a moment. Originally only in the Windows version, they have been migrated to the Macintosh version as well and prove quite helpful.

c) Open “venice.psd” in Photoshop. Choose the Paintbrush icon and make a random swipe upon the image. Choose the Pencil icon and drag a line across the image. Choose the Eraser icon beside it and drag over part of the image, erasing it. If you like, make one or two other actions upon the image with any tool of your choice.

Open the History palette by clicking on the History/Actions palette. If it’s not onscreen, choose Show History from the Window menu in the menu bar at the top of your screen. How can you use this function of Photoshop to remove the marks you have made upon your image?

Answer: The History palette that was developed for Photoshop 5.0 was designed as a means of multiple Undo. It shows the entire sequence of actions taken that have modified an image. Each of the tools with which you made a mark on your image is listed.
Click on any of them to see the previous state of the graphic, and as you move to the top of the list each subsequent action performed on the graphic disappears. With this capability you are—or your graphic is—literally going back in time!

A philosopher once wrote that the greatest revolution in the personal computer was the invention of Undo. With readily accessible Undo capability, the novice could explore the tools freely without irreparable destruction of one’s work. However, until Photoshop’s History palette, most applications’ Undo capability regarding an action was immediately obliterated with any subsequent action.

In Exercise 1.1.1 we promised you a third way to Undo, and this is the most interesting and unique to Photoshop.

On the Menu bar choose from the Window menu Show History. The History palette shows all the actions taken upon your file, the most recent at the bottom. After performing multiple actions upon an image that you decide are not satisfactory, you have the power of a multiple Undo with the History palette. By vertically dragging the slider on it you are able to “go back in time” as far as necessary to return to the state with which you’re satisfied. The History palette is nonlinear, allowing you to branch off from a past state, work on it a while, yet still return to previous states that followed from where you branched. It is a welcome and exciting feature . . . and one of the reasons Photoshop demands a lot of operating memory in RAM.

d) Suppose you are ready to save the work you performed upon a graphic project. Open the File menu on the menu bar at the top of your screen and choose Save for Web. What do all these multiple images and choices presented to you mean?

Answer: Later you will learn why it is essential to save a graphic at the smallest possible size for display on a page on the World Wide Web. Photoshop 5.5 gives the user previews of different file formats from which you can choose to best save your image for the Web. This allows the designer to determine the proper tradeoff between image quality and file size for this specific graphic, in this specific case. This capability will be explored in detail in Chapter 10.

For the user’s information—and this won’t really be clear to you until you have worked with the program more fully in the ensuing chapters—further enhancements were added to Photoshop 5.5. Masking capabilities were enhanced with the addition of the Background Eraser and the Extract Image command. The Art History brush can be used to give a painterly effect such as brushstrokes in a traditional painting medium. The Color Management Assistant was added for more precise color settings, and contact sheets of images could be quickly displayed a Web page from their folder. Editable layers for text were added, as well as layer effects and layer alignment and a new ability to blend channels. The addition of a magnetic Lasso tool and Reselect command enhanced selection capabilities. Transformations could be applied to selections and Paths, Magnetic, and Freeform pen tools were added. Wizards and
Assistants now can be used to automate tasks, more tools were given live previews, and color and printing was improved.

d) Click on the little Adobe logo at the lower right bottom of the toolbox, whose Tooltip tells you it is the Jump to command. What takes place?

**Answer:** The Jump to command on the Photoshop toolbar allows the Photoshop user to move to the image processing program ImageReady 2.0, so the reader will note that his or her toolbox is noticeably different, though containing many of the same tools seen in Photoshop. The ImageReady 2.0 application prepares a graphic for the Web with compression methods and control of the export, slices layered images, and applies compression settings to each, and writes the necessary HTML code to display them all properly onscreen. Web-safe colors are specified with their hexadecimal values.

Using ImageReady, layered Photoshop or Illustrator files can be turned into GIF animations. The program also lets the designer produce JavaScript rollovers and animated rollover behavior.

The addition and integration of ImageReady 2.0 was probably largest innovation in Photoshop 5.5. The capabilities of ImageReady will be explored in detail in Chapter 11.

**Lab 1.1 Self-Review Questions**

In order to test your progress, you should be able to answer the following questions.

1) What are some important aspects of the Photoshop interface?
   a) _____ Menus
   b) _____ Windows
   c) _____ Toolbar
   d) _____ Palettes
   e) _____ All of these

2) Photoshop v. 1 meant a working set of tools and capabilities had come together into a coherent product.
   a) _____ True
   b) _____ False

3) Layers were always a part of Photoshop.
   a) _____ True
   b) _____ False
4) Photoshop’s interface has always stayed the same.
   a) _____ True
   b) _____ False

5) ImageReady has only been integrated with Photoshop fairly recently.
   a) _____ True
   b) _____ False

Quiz answers appear in Appendix A, Section 1.1.
There are differences between the Windows and Macintosh interfaces. Many of the most fundamental are behavioral. Windows often sets conditions for some action on the computer then performs the action, rather than acting then modifying, which is the usual behavior of actions on the Macintosh. Some of these differences are cosmetic, like a different use of gray and white for backgrounds or Windows’ blue versus Mac’s striped lines on the title bar of the selected window. Other differences are the nature of pull-down menus and a different, though similar, set of key commands. Note the interface of Photoshop running under Windows (Figure 1.5) and Photoshop running on the Macintosh (Figure 1.6).

Photoshop has been carefully designed to operate as similarly as possible for both Windows and Macintosh users, while respecting the behaviors and consistency you expect from your specific computer platform.

One difference between Windows and Macintosh is that a command that uses the Alt key in Windows usually uses the Option key on the Macintosh. In other cases the Command key in Windows is used, when the Control key
is used on Macintosh. This book will use the convention “Alt/Option” or “Command/Control” plus the appropriate letter key (i.e., Alt/Option-click or Command/Control-d) when giving a key command for greater efficiency. It means the key preceding the slash is the Windows version, and the key after the slash is the Macintosh version.

It is necessary for a designer to have easy familiarity with both Windows PC and Macintosh platforms in these days of contract employment and rapid change. Yet that doesn’t always mean the designer has machines in each platform available. There can be problems when presented with files from the operating system that’s not on your desktop, but there are also solutions.

First of all, Photoshop shares files among Adobe products Illustrator, InDesign, and Acrobat on Windows or Macintosh platforms. If these are the only programs with which you work, you won’t have problems.
There are Macintosh-to-PC tools for file exchange and compatibility: MacIn-DOS 3.0 from Pacific Micro (www.publishingperfection.com) works under Windows Explorer, Windows 98 and Windows desktop to exchange files between Mac and PC. It allows user to see the Finder information on Mac OS files and use it to create additional file type associations to make file transfers more easily. MacIn-DOS 3.0 lets you read, write, and format Mac diskettes and other removable storage media on Win 95/98 or NT 4.0 PC.

There are Windows-to-Macintosh tools: There have been PC emulator cards available for the Macintosh since the days of Windows predecessor MS-DOS. The Macintosh operating system itself has the ability to recognize and copy Windows-formatted files and floppies.

Files can be shared between Windows and Macintosh with certain products: MacDrive 98 from Media4 Productions (www.media4.com) can be used to read hard drives, floppies, and portable media from Windows 95, 98, and NT 4.0. It also formats Macintosh disks.
Finally, there’s the Web, which is helping to make the tower of Babel between systems irrelevant. The World Wide Web is the greatest factor fighting platform incompatibility. HTML is designed (though there are platform-specific issues to some tools) to be able to be read by browsers on all platforms, including UNIX workstations, as are the GIFs and JPEGs that make up most graphics on the Web. The nature of GIFs and JPEGs will be explored in detail in Chapter 10.

Macintosh monitors are 72 pixels per inch (ppi), while most Windows PC monitors are 96 dots per inch (dpi). This means that graphics created for the Web on the Macintosh will look smaller in a browser running on the monitors of a Windows system, and that graphics created on a Windows monitor will look larger on a browser running on a Macintosh.

Notes on the Macintosh

The Macintosh—whose best graphical user interface ideas were adapted from the Xerox Star computer—maintained hegemony with the graphic design community for many years. Until the 1990s much more attention was paid to design and testing of the Mac’s interface—and evangelization of standardized interface elements and behaviors to third-party developers—than went into Windows or its third-party applications.

Ted Nelson (www.sfc.keio.ac.jp/~ted)—the conceptual father of interactive cyberspace—was one of the first to critique the graphical Macintosh interface and its quirkiness (i.e., asking what does the Finder find?). Since then Donald Norman, Jakob Neilsen, and others have critiqued it from within and without Apple Computer, Inc. During different periods of their corporate histories Apple and Microsoft have each led in attentive and innovative interface design and development; Microsoft gets points for its groundbreaking but unpleasantly implemented system of cartoon Help agents called “Bob” that was released shortly before Windows 95.

Because Apple Computer, Inc. had management problems for much of the 1990s, market share was lost to Intel PCs running Windows, so this platform’s interface standards became entrenched along with its market dominance. Someone once observed you stick with the first word processing program you learned, and for most people that’s also the case with computer operating systems.
Monitors have their own color casts, which can greatly affect how graphics are perceived on them. Often Windows monitors appear darker than Macintosh monitors, for their gamma is calibrated to 2.5 while the Macintosh monitors are calibrated at 1.8. Monitor calibration can be checked at www.natureimages.com. For more information on color, please see Chapter 8.

**Lab 1.2 Exercises**

1.2.1 **Understand Windows PC and Macintosh Differences**

a) Why is multiple platform compatibility so important on the Web?

b) What are problems involved in establishing interface standards? Why are standards desirable?

c) In your opinion, is it a good or bad thing that there exist both the Windows and Macintosh operating systems?
LAB 1.2 EXERCISE ANSWERS

This section gives you some suggested answers to the questions in Lab 1.2, with discussion related to those answers. Your answers may vary, but the most important thing is whether your answer works. Use this discussion to analyze differences between your answers and those presented here.

If you have alternative answers to the questions in this Lab, you are encouraged to post your answers and discuss them at the companion Web site for this book, located at http://www.phptr.com/phptrinteractive.

1.2.1 ANSWERS

a) Why is multiple platform compatibility so important on the Web?

Answer: From the start it was the intention of the designers of the Web and its formatting language HTML that it present documents (pages) readable on all computer platforms. Besides Windows and Macintosh, this includes workstations running various forms of UNIX and LINUX and interactive televisions like WebTV (acquired by Microsoft, source of Windows). Development is now going on to make the Web readable on handheld devices like the Palm, in displays embedded in telephones, and devices that are going to surprise us all.

b) What are problems involved in establishing interface standards? Why are standards desirable?

Answer: The central problem beyond engineering would be getting software developers to buy into it and agree to develop applications that run under that engineering, work that way, and adhere to its principles.

If you are manufacturing hardware, you want to see standardization so many applications by third-party developers can run on your machines—making them consumers’ top choice for purchasing. By first providing an operating system twenty years ago for IBM personal computers, Microsoft’s MS-DOS became a standard by running on other manufacturers’ IBM compatibles. Consequently, Microsoft remained market leader when MS-DOS was replaced by Windows.

Apple coined and popularized the term “Evangelist”—there were people with that title on their business cards. It made sure when the Macintosh was launched there were strong applications available for it from major software developers, including Microsoft. The Interface Evangelist also provides information and code to help and influence third-
party developers to make their applications behave in the expected way. This means that if you know how one application on that platform behaves, your assumptions will help you get up to speed on others.

**Interface Evangelism** is the business function of the machine’s visual and behavioral design. Designers will understand the Evangelist’s efforts of pitching a way of doing things, a look and a feel. Much about the topic has been published in books and articles by Guy Kawasaki. Web designers can benefit from his experiences among many developers over the years.

c) In your opinion, is it a good or bad thing that there exist both the Windows and Macintosh operating systems?

**Answer:** Your own answer and reasons may be different, but people have argued that competition promotes innovation. Yet it was during the years when Apple was not an especially robust market challenger that Windows most refined its interface behavior and standards. It’s obviously a drain of resources for developers to dedicate resources to developing for more than one platform.

Perhaps the Web will further level the playing field. There may someday be graphics tools that reside upon the Web server and are used only when online.

Finally, who knows what business decisions between Microsoft and Apple (and other developers) may have taken place and influenced operating systems by the time you read this?

**Lab 1.2 Self-Review Questions**

In order to test your progress, you should be able to answer the following questions.

1) Which of the following are ways that a Macintosh file can be opened by a PC running Windows?
   
a) _____ An emulator function  
b) _____ Using networking tools  
c) _____ Neither of these  
d) _____ Both of these

2) A Windows file can be recognized by a Macintosh regardless of what programs are loaded.
   
a) _____ True  
b) _____ False
3) Some programs allow the user to open a Windows file on the Macintosh.
   a) _____ True 
b) _____ False

4) Emulator files and networking tools can help open files across platforms.
   a) _____ True 
b) _____ False

5) A Web designer should learn to work on _______.
   a) _____ Windows 
b) _____ Macintosh 
c) _____ Both platforms

Quiz answers appear in Appendix A, Section 1.2.
Images in a variety of image modes can be opened or saved in Photoshop. You will probably save your work in progress in native Photoshop file format. You will probably be saving your images for the Web as either GIFs or JPEGs. You should become familiar with all of these, since you may find yourself converting an image that comes to you in one format into another one that’s Web-friendly.

Digital resolution is very different from printed resolution. Print demands much greater resolution for satisfaction than screen delivery . . . or perhaps the public is too easily satisfied with low resolution screens. The unit of measurement for each is in dpi or ppi, meaning dots per inch or pixels per inch, yet it is under 100 for Web images at this time (96 for Windows, 72 for Mac), while usually over 1,000 for a continuous tone color photograph in print.

An image can be created from scratch in Photoshop, a digitally created painting or drawing. Yet Photoshop is most celebrated for its manipulation of photographic images. There are several ways of bringing an image into the application: loaded from a digital camera, snapped from a video camera or video segment, or scanned with a flatbed scanner.
Scans are often resampled, where a higher-resolution image is sampled at a lower rate for a screen resolution image that’s much smaller and hence loads more quickly on a Web page.

It’s a guideline that scans always need tweaking.

Some Notes on Scanning

Think of scanning as a travel ticket. You want the cheapest possible, but don't want to sacrifice comfort beyond a certain level. In your scanned image you want your file as small as possible, yet of acceptable quality.

Whatever make of scanner you have, here is some generic scanning information. The scanner you are using may prove easier or harder to use. Web images and color will be covered in depth in Chapters 8 and 12.

1. Usually for images that will end up on the Web, you will want to scan at grayscale, Web colors or 256-color (photos), or line art (ink drawings). Scanning at a higher resolution may be useful if you plan to manipulate your images in Photoshop.

2. Save your images at 96 dpi on Windows PC or 72 dpi on the Macintosh. Your scanner software may have a setting called something like “Web color.” You will ultimately be saving your files as GIFs (with .GIF extension on name) or JPEGs (.JPG extension).

3. An ink drawing, logo, or text should be scanned at setting called “line art” or “document,” which produces the highest contrast between black and white. If you scan a photo (black and white or color) at this setting, you'll get an interesting high-contrast effect like a Cuban poster, but you will lose detail.

4. Give yourself time to experiment with the scanner. Default settings can be pretty good, but figure the first scan is just a test to tell you what you need to tweak—more/less brightness, more/less contrast, and so on. A scan is rarely completely right the first time.

5. JPEGs and GIFs are usually less than 50K, so if your files are much larger than this, they’re probably bigger than necessary.

6. Make sure you know to where on your hard disk or Zip drive your scanner is saving. It’s easy to scan and then have a hard time finding the file.
When you are finished working in Photoshop, you have several choices for saving your files. Save writes over any previous version of the file you're working on, wherever it resides. Save As initiates the first save and requires you to define a destination for the saved file. Save a Copy saves a duplicate copy to the destination you define, while keeping the previous file on which you’d been working.

Save for Web is a very welcome alternative that was added to Photoshop 5.0. This brings up controls that allow you to minimize the size of the image so it will load on your Web page most quickly, yet shows you the image so you can decide if the quality is acceptable.

There is the issue of version compatibility if you are working and saving your file on multiple computers. Remember that an application can usually open a file from a lower version, but not always a higher one. This often greatly affects students who have different versions of an application at home from the one on the school lab machine. If the student does work in the higher version and saves it, it may not open on the other machine.

**Lab 1.3 Exercises**

**1.3.1 Employ Image Modes**

- **a)** Open Photoshop and choose New from the File Menu. A dialog box appears, and from it—about halfway down—choose Mode. What is the first choice that appears?

- **b)** In the same dialog box the second choice is Grayscale. What is that?
c) The next choice is RGB. What is that and what do the initials stand for?

d) The fourth Mode choice is CMYK. What is that and what do the initials stand for?

e) From the menu bar at the top of the screen choose Image and then Mode. Here the choice following Grayscale is Duotone. What’s that?

f) From the menu bar at the top of the screen choose Image and then Mode. Here the choice following Duotone is Indexed Color. What’s that? (Hint: It has to do with the Web.)

1.3.2 Set Up and Get Started

a) After opening Photoshop, the first three choices on the File menu that are available to you (not grayed out) show you what you can do to begin working. What are they?

b) What are your choices if you choose to Import a file?
Lab 1.3: Setting Up and Getting Started

(c) From the File menu you have the ability to set preferences for your version of Photoshop. What Preferences can be set here?

(d) Open “car.psd” (Figure 1.7). You decide it’s too large and want to change it to 80% of its present size. How do you do that?

(e) You now like the size of the car in the image, but would like to have a 1" empty margin around it. How would you do this?
32 Lab 1.3: Setting Up and Getting Started

f) You would now like to check the exact size of the car in your image. How can you do that?

   [Blank]

   [Blank]

g) You are now ready to save your file under the name “biggercar.psd.” Where will you save it to?

   [Blank]

   [Blank]

Lab 1.3 Exercise Answers

This section gives you some suggested answers to the questions in Lab 1.3, with discussion related to those answers. Your answers may vary, but the most important thing is whether your answer works. Use this discussion to analyze differences between your answers and those presented here.

If you have alternative answers to the questions in this Lab, you are encouraged to post your answers and discuss them at the companion Web site for this book, located at http://www.phptr.com/phptrinteractive.

1.3.1 Answers

a) Open Photoshop and choose New from the File Menu. A dialog box appears, and from it—about halfway down—choose Mode. What is the first choice that appears?

   Answer: Bitmap is the first choice that appears.

   Bitmap is a somewhat confusing term here, since all Photoshop images—as well as images on the Web—are bitmapped. Bitmap mode in Photoshop has usually meant one-bit black and white image, where each pixel is either black or white, with no smoothing, no antialiasing (you’ll learn what that means). In this mode you can’t use filters or Photoshop’s Smudge, Blur, Dodge, or Burn tools.
Windows has the BMP bitmap format native to the fairly primitive Windows Paint program, which can be opened and converted in Photoshop. The Macintosh version of Photoshop can open or save to this format as well.

b) In the same dialog box the second choice is Grayscale. What is that?

Answer: Grayscale is an 8-bit image, like a subtly toned black and white photograph. Eight bits means 256 colors, so each pixel has a grayscale value from 0 for black to 255 for white. This means there are 254 possible grays in between them. There exist 16-bit grayscale images, which in Photoshop can be saved as TIFFs for printing, but you won’t be using them on the Web.

c) The next choice is RGB. What is that and what do the initials stand for?

Answer: RGB is the default mode of the full-color Photoshop file you create. The initials stand for the colors Red, Green, and Blue, because colors are created with an additive mixture of those three colors. Photoshop’s present default is also 24-bit color, which means a number in the millions. To the designer this power at first appears much like Carl Sagan waxing poetic about “billions and billions of stars” on his 1970s television specials.

d) The fourth Mode choice is CMYK. What is that and what do the initials stand for?

Answer: CMYK is the world’s four-color printing standard. Its initials stand for cyan, magenta, yellow, and black. You need to know if your Web design process includes collaboration with someone who’s working in imagery for print. Images from print production can be repurposed for Web use much more easily than Web images can be repurposed for print, as the print images are much larger and can readily be downscaled to screen resolution. Enlarging an image from the Web is usually much less successful.

e) From the menu bar at the top of the screen choose Image and then Mode. Here the choice following Grayscale is Duotone. What’s that?

Answer: Duotone is a grayscale image in black and gray, or a grayscale with spot color of increased tonal range. Duotones are often attractive imagery and one more way of coloring black and white images for the Web.

f) From the menu bar at the top of the screen choose Image and then Mode. Here the choice following Duotone is Indexed Color. What’s that? (Hint: It has to do with the Web.)

Answer: Indexed Color is a method of scaling down an image’s colors to 8 bits, or 256 colors. This allows for a file to be saved as a GIF. This file format’s capabilities and limitations will be discussed in Chapter 10.
1.3.2 Answers

a) After opening Photoshop, the first three choices on the File menu that are available to you (not grayed out) show you what you can do to begin working. What are they?

Answer: New, Open, and Import.

You can create a New file. A dialog box will come up and ask you the image Size, and this can be measured in units you choose. Next it will ask you about the screen Resolution and the Image Mode. Finally, it will ask you the contents of the File: This can be white, another background color you've selected, or transparency.

You can Open an existing graphics file that can be read by Photoshop.

You can also Import a file from other compatible programs.

b) What are your choices if you choose to Import a file?

Answer: You can import an antialiased PICT or you can import a PICT resource. You can choose a Twain Acquire or Twain Select from certain types of scanners. If your computer is connected to a scanner, check your scanner documentation to see if this is applicable.

c) From the File menu you have the ability to set preferences for your version of Photoshop. What Preferences can be set here?

Answer: The Preferences the user can set include General Preferences, for a variety of global characteristics that include whether to show Tooltips.

Preferences for Saving Files include the nature of previews, thumbnails, and whether file extensions are added as necessary (such as .jpg, necessary for JPEGs to be displayed on the Web).

Display and Cursors Preferences group those affecting the screen with choices of Standard, Precise, or Brush-sized cursors when using painting tools, or Standard and Precise pointing cursors.

Transparency and Gamut Preferences determine the gray and white checkerboard representing transparency. The dark gray represents unprintable out-of-Gamut colors, but this is not relevant to Web design.

Preferences for Lines and Rulers determine the units. Picas are used in the printing industry.

Guides and Grid Preferences allow the user to choose colors and size of grids for on-screen alignment.
Plug Ins and Scratch Disks Preferences let you block off areas of memory for the processing of your image in Photoshop.

Image Cache preferences affect how a color histogram will be sampled from an image. Color Settings will be discussed in Chapter 9.

In every tool and palette in Photoshop there will always be the default preferences, where the tool is set when you first open the application. You may be content with all of Photoshop’s default settings for this work session or particular project, or you may just find yourself changing several.

d) Open “car.psd.” You decide it’s too large and want to change it to 80% of its present size. How do you do that?

Answer: You can resize your image, but remember that information is lost with each shrinking, so it’s prudent to save a copy of the original image by choosing Save As for the new version.

From the Image menu choose Size to bring up the Image Size dialog box. It allows you to adjust pixel dimensions, pixels-per-inch resolution and note the change in file size. When you enter new values into pixel dimensions and resize the image by enlarging it, you will see everything stretched. To enlarge or shrink in only one dimension—vertical or horizontal—uncheck Constrain Proportions, and you will see the little chain icon links disappear.

Print Size defines the size of your image for printing, if slated for paper output.

Resolution is shown in points-per-inch, into which you can enter a new value.

You can choose to Resample Image, for Upsampling or Downsampling. Upsampling is rarely used, because this commands the computer to add color pixels and make the file bigger. The result is often rather inaccurate or unfocused.

Three kinds of resampling are Bicubic, Bilinear, Nearest Neighbor. Bicubic is usually most accurate, because it uses complex equations, whereas the other sets the color in relation to—or in Nearest Neighbor, simply copies—pixels around it.

It is important to remember that on the Web, a dynamic communications medium that is sending files over great distances to load on the viewer’s computer, the smaller the graphics file the better. Small as possible, simple as possible. Size translates into time (and time is money), and viewers today are no longer so awed by the novelty of the Web that they’ll sit still while a graphic takes 30 seconds or more to download and become visible. One guideline is that if a page takes longer than eight seconds to fully load, your viewer has likely gone someplace else.
Photoshop creates a second copy when you’re working on a file, which is why it requires a surprisingly large amount of hard disk space while you are working.

Similarly, as you work in PhotoShop you balance occasionally flattening layers with the need to keep them for future modification. Further information about layers can be found in Chapter 3.

e) You now like the size of the car in the image, but would like to have a 1" empty margin around it. How would you do this?

Answer: To add a margin, choose from the Image menu Canvas size. This brings up a dialog box.

Canvas size is the size of your work area. If you enlarge the canvas size by entering one or more higher numbers, your image stays the same but has more empty space around it.

By default the Anchor is the center, and margins are added around your centered original image. Click on one of the other squares to move the anchor to the upper or lower left, center or right edges. The additional margin is then added asymmetrically.

f) You would now like to check the exact size of the car in your image. How can you do that?

Answer: From the toolbar choose the Measure tool by clicking on that little ruler icon. The Measure tool measures distance (D) between any two points on the image, plus X and Y coordinates of the point of origin. It also shows the horizontal (H) and vertical (Y) distances traveled from the x and y axes, plus the angle relative to the axis. Adding a second measuring line will create a protractor that measures the angle between them.

For more information on the tools on the toolbar, see Chapters 2 and 4.

g) You are now ready to save your file under the name “biggercar.psd.” Where will you save it to?

Answer: You may save your file to your computer’s hard disk or to a portable medium like a Zip disk. Wherever you save it, it is imperative that you know where it is.

Remember to Save!

Needless to say, saving your files is important . . . and since your files are important, be sure to save multiple copies.

One veteran digital media professor at a California university described her guideline. She figures that in each semester, out of a class
of 20 upper-level students (seniors and grads), there will be 1 student who loses the only copy of his or her final project because of media failure—bad floppy disks, videotape breaking, etc.—and 2 more students who will lose their work because of simple bad habits (forgetting to save, leaving work on the class hard disk and returning to find it erased by lab monitors, etc.). Don’t let any of these unnecessary disasters happen to you and your work. Observe excellent housekeeping habits with your work at all times. Be finicky and save multiple copies of your work after each session.

Work out a system of labeling each file and stick to it. Do your spring cleaning and erase all the old versions after the product ships (though you might want to save some alternative efforts in a personal or departmental “junkyard” for future reference).

**Lab 1.3 Self-Review Questions**

In order to test your progress, you should be able to answer the following questions.

1) With which of the following ways can images can be brought into Photoshop?
   a) _____ Import them from CD or PhotoCD.
   b) _____ Draw or paint them using Photoshop’s tools.
   c) _____ Scan a photo or drawing with flatbed or drum scanner.
   d) _____ Download the image from the Internet.
   e) _____ Import the image from another graphics program, like Illustrator.
   f) _____ Import them directly from a digital camera.
   g) _____ All of these.

2) I’ve turned on my scanner, launched the software, and immediately scanned the image . . . but it’s not quite right. My scanner is obviously broken.
   a) _____ True
   b) _____ False

3) The size of your image is
   a) _____ The print size.
   b) _____ The resolution.
   c) _____ The amount of memory.
   d) _____ All of the above.
4) The faces in a photo of a crowd scene are too small. I’ve scanned the image and opened it in Photoshop, now I’d better give it a bigger Canvas size.
   a) _____ True
   b) _____ False

5) Upon launching Photoshop at the beginning of a project,
   a) _____ You must work with Photoshop’s default Preferences settings.
   b) _____ You must change all of Photoshop’s Preferences settings.
   c) _____ You may have to change some of Photoshop’s Preferences settings.
   d) _____ You can work within the Preferences settings that come up from your previous session working in Photoshop.
   e) _____ Either c or d

Quiz answers appear in Appendix A, Section 1.3.
The projects in this section are meant to have you utilize all the skills that you have acquired throughout this chapter. The answers to these projects can be found at the companion Web site to this book, located at http://www.phptr.com/phptrinteractive. Visit the Web site periodically to share and discuss your answers.

1) What would you like to see added to Photoshop? Begin a wish list of desired features then see if subsequent Chapters 2 through 7 don’t show that Adobe has already thought of them and they’re already incorporated in Photoshop. Send your answers to this book’s Web site and some of the most interesting answers will be posted there.

2) Begin to look at digital photography upon the Web. Study the commercial (and fine art) styles to be found there. Visit a catalog of clothing, of housewares, CDs, and the sites of some automobile manufacturers. Note their effectiveness in clearly or evocatively depicting their products.

3) Research the following interface design developers, innovators, and innovations by performing a Web search or in your corporate or college library:
   • Doug Engelbart
   • Microsoft’s Bob (1994)
   • MagicCap (1992)
   • Ted Nelson
   • Apple’s HyperCard (1987)
   • Frox
   • Tim Berners-Lee
   • Marc Andressen

Think about why each one was or wasn’t successful in the marketplace at that time. What lessons does each have for the contemporary designer of media on the World Wide Web?

4) Think about the future of the desktop interface and the hardware with which you log on to the Web today. Where do you think it will be in five years? Ten years? Twenty years?

5) Think about the future of the Web. What will be the nature of information on the Web in five years? Ten years? Twenty years?